は重要な記事












Top > AviUtl拡張編集(2) > 過去のコメント/ 2018年08月10日 (金) 20時18分01秒

◆質問時に書いてほしいこと

説明
OS・アプリ・周辺機器 どのような環境なのか、なにを使用しているのか
具体的な状況 なにをしたのか、どう設定したのか、どうしたいのか

◆質問時に避けたい表現

説明
エラーが出ました どのようなエラーが出たのか正確に書く
解説のとおりにやりました なにをやったのか、念のため書く
いろいろやりました なにをやったのか具体的に書く
それはもうやりました 自分がやったことは最初に書く

※URLを含むコメントを投稿したい場合は、「http」ではなく、「ttp」と記述していただくようお願いいたします。スパム対策で「http」を含むコメントは投稿できないようにしています。
※コメントの投稿に失敗する場合があります。そこで、念のためコメントをコピーしてから投稿することをお勧めします。やり方は、Ctrl + Aを押したあとCtrl + Cを押します。投稿に失敗した場合は、Ctrl + Vでコメントを貼り付けて再度投稿してください。

2018年


名前:
コメント:

  • >名無しさん
    ありがとうございます。
    URLを修正しました。


    ttps://videoinfo.tenchi.ne.jp/?DirectShow%20File%20Reader%20%A5%D7%A5%E9%A5%B0%A5%A4%A5%F3%20for%20AviUtl -- 管理人 (2018-08-10 20:18:01)

  • DirectShowFile Readerをダウンロードするとパスワードが要求されます。
    これはこちら側のパソコン自体に問題があるということでしょうか? -- 名無しさん (2018-08-10 19:12:36)

  • ↓恐らく既に読んでいらっしゃるかと思いますが、
    こちらのサイトの通りに数字を入力できているか確認してください。


    ttp://aviutl.info/l-smash-works-22/#VFR-gtCFR
    ttp://aviutl.info/otozure/


    それでもやはり音ズレする場合は、
    今度はこちらのサイトにある方法で動画を読み込んでみる
    というのはどうでしょうか。


    AviUtlだけで、NVIDIAのShare(旧ShadowPlay)における「音ズレ」問題を解決する方法。
    ttps://kakihey.com/entry/how-to-fix-the-sound-bug-shadow-play/


    D&Dせずに、拡張編集のメディアオブジェクトの追加から
    「動画ファイル」で動画を読み込みます。
    動画を読み込んだら、同じようにメディアオブジェクトの追加から
    「音声ファイル」で動画を読み込んで音声を追加します。
    最後に余分な部分を分割してカット削除します。 -- 名無しさん (2018-04-08 15:11:08)

  • Win10環境でゲーム画面をShadowPlayを使って録画しました。長さは01:40ほどです。
    録画して出力されたMP4をAviutlの拡張編集にD&Dしてチェックしていたのですが次第に音ズレが発生していることに気付き、調べた結果VFR→CFR変換が必要だということでしたが…。


    本題ですがHandBreakなどを使用しCFR変換する方法は非常に時間がかかるのでAviutlのプラグインであるL-SmashWarksの変換機能を使ってAviutl上でCFR変換をしたかったのですが
    いくら試してみても変換が機能せず音ズレが解消されませんでした…。
    元データが音ズレしていないのは確認済みで、拡張編集ではなくAviutl本体に読み込ませると音ズレが起きない(システム設定の0.1秒以上のずれが~を有効にしている場合)ので無圧縮出力でCFR変換するという方法も出来ますが
    それだとHandBreakと大差ない時間がかかるのでL-SmashWarksの機能を何とかして使えるようにしたいです。よろしくおねがいします。 -- 名無しさん (2018-04-07 22:43:34)

2017年


  • ↓とすると、フレームレートがおかしいのが原因かもしれません。
    3分46秒の動画で30fpsの場合、フレーム数は226×30で6780に
    なるはずですし、60fpsなら13560になるはずです。
    でもなぜか、フレーム数が4853になっているわけですよね。


    MMDの「ファイル」→「AVIファイルに出力」でフレームレートの
    数字を正しく設定できていますか?
    あるいはMMDの「表示」のfps無制限、30fps制限、60fps制限、
    この辺も関係しているのかもしれません。


    ついでにAviUtlの方では
    動画を読み込む時に「読み込むファイルに合わせる」の
    チェックを外した状態でフレームレートを小さく設定すると、
    やはり動画が短くなります。


    あとはこういう情報が載っているサイトもありましたよ。


    [MMD]avi出力したらfpsが半分になった件」が解決した件
    ttp://ch.nicovideo.jp/rossi_bi/blomaga/ar920911 -- 名無しさん (2017-09-26 19:49:31)

  • 灰色の縦線は赤と青の帯の右端に表示されてます。 -- ちょっと (2017-09-26 06:39:34)

  • ↓動画をAviUtlで読み込んだ直後の時点でおかしいんですよね?
    ひょっとして、青色と赤色の帯の途中に
    灰色の縦線が表示されていませんか?
    その場合は、「ファイル」→「環境設定」→「システム設定」で
    最大フレーム数を増やし、AviUtlを再起動して動画を読み込みます。 -- 名無しさん (2017-09-26 01:30:57)

  • MMDの「ファイル」→「Aviファイルに出力」で録画フレームの数字の確認をしましたが、問題はありませんでした。
    出力は、未圧縮で出力してます。フレーム数は4853になってます。
    ですが、エンコードしたものをAviUtlの方で読み込むと、録画フレームが170になってしまいます。
    -- ちょっと (2017-09-25 23:10:42)

  • ↓MMDの「ファイル」→「AVIファイルに出力」で
    録画フレームの数字が正しく設定できているか確認してください。
    そこが問題ないのであれば、「ファイル」→「AVIファイルに出力」で
    ビデオ圧縮コーデックがUtVideo RGBAなり、未圧縮なりを選び、
    エンコードしたものをAviUtlの方で読み込んでみてください。 -- 名無しさん (2017-09-25 17:49:53)

  • MMDの動画を編集しようとしたのですが。
    拡張編集にAviファイルをドラッグ&ドロップすると、ビデオツールでは3分46秒あるAviファイルの動画が、拡張編集のオブジェクトでは5秒に短くなってしまいます。
    オブジェクトを引っ張ると音楽ファイルは伸びるのですが、動画ファイルは伸びません。
    初めてMMD動画を編集した時のAviファイルは正常に読み込まれました。
    何が原因か調べても同じような問題が記載されていなかったので、解決策をどうか教えてください。 -- ちょっと (2017-09-24 17:27:31)

  • 編集したあとの音声と編集する前の音声が重なって聞こえます。編集した後の音声はオブジェクトでどうにでもなるのですが、編集する前の音声はオブジェクトが表示されず編集のすべがなくて困っています。
    -- 玲唯 (2017-04-21 18:43:17)

  • ↓iniファイルの編集ではどのような拡張子を追加しましたか?
    また、拡張編集プラグインのファイルはaviutl.exeと同じ階層に
    置いていますか?
    Pluginsフォルダを作ってその中に拡張編集プラグインの
    ファイルを置いているなら、
    いったんaviutl.exeと同じ階層に置いた上で動画を読み込んでください。


    それで駄目ならAviUtl本体で動画を読み込んで
    utコーデックでエンコしたものを拡張編集で読み込めば
    対処はできます。


    ttps://www18.atwiki.jp/live2ch/pages/379.html#id_97b49ca4 -- 名無しさん (2017-04-20 17:47:45)

  • 追記
    PC自体は1年ほど前のもので動画編集関連のソフトは他に入れてません -- ケン (2017-04-19 20:42:11)

  • 動画を読み込めません。
    拡張編集からドラック&ドロップでMP4ファイルを置いても真っ暗です。
    ・ini編集、プラグインの優先順位は試しました。
    ・元の動画ファイルはグラボで撮ったやつと数年前にaviutlで編集したものです。
    ・どちらのファイルも通常の読み込みでは問題ありません。 -- ケン (2017-04-19 15:53:31)

  • 音声ファイルがm4aなのですが、これだと読み込むことができず、
    エラーを意味する音声がなります。
    変換すればいいですかね・・・? -- (2017-02-06 21:09:37) (2017-02-14 22:59:36)

  • ↓すでに音声ファイルがあるなら、動画を読み込んだ後に
    音声ファイルを読み込むだけです。
    ttps://www18.atwiki.jp/live2ch/pages/309.html#id_f4bf3417 -- 名無しさん (2017-02-06 22:35:41)

  • 映像と音声の合成の仕方ってどこかにかいてありますか?
    なかったら教えて下さい。
    あと具体的にかけずにすいません。 -- japanese (2017-02-06 21:09:37)

2016年


  • さきほどのズレが生じることのコメントでの者ですが
    補足なのですけども、
    もし画面が真っ暗な場合の時の対策での記事のご説明で、AVI/AVI2 File Readerを優先に一番上にも設定して、mp4読み上げもしたり。
    L-smash(間違ってたらすみません)も、優先を1番上に設定したりもしました。 -- 名無しさん (2016-07-15 05:56:02)

  • 質問失礼します
    mp4のファイルで保存したものを、
    編集した際に、開くでmp4をD&Dして、
    映像と、音声読み込みができるものの、メイン画面上には映像が映し出されず真っ暗となり、
    再生ボタンを行えば、音声は流れ出し再生されているみたいでした。


    ただ、メイン画面上にd&Dすれば、映像を映し出すことができます。
    しかし、それらをカット編集した場合に、タイムライン上の音声と、映像をカット編集すれば、それらがカット編集となり、
    メイン画面上の映像はカットされないままとなります。
    双方にズレが生じてしまいます。
    カット編集を片方だけがカット編集されるようなズレが生じることなく、編集したいのですが、
    どのような設定、もしくわ、編集をすればよいでしょうか?


    長文失礼しました。 -- 名無しさん (2016-07-15 05:51:51)

  • aviutlの拡張編集で、拡張子が.aviの動画のファイルを拡張編集のレイヤー1にドラッグアンドドロップしたのですが、なぜか音声が読み込まれません。
    解決法はありますか? -- 名無しさん (2016-07-10 12:39:46)

  • ↓いったんプロジェクトを保存して、もう一回動画を読み込んで
    何も編集をしていない真っ更な状態(ここ重要!)で倍速編集できるか
    やってみてください。
    それで何が原因で上手くいかないかわかるかもしれません。


    それで駄目なら、動画を分割して倍速編集する方法もあります。
    1.動画をAとBに分割します
    2.Bの再生速度を200にします
    3.動画をBとCに分割します
    4.Cの再生速度を100に戻します


    細かい手順は省きますが、だいたいこんな感じでいけるはずです。 -- 名無しさん (2016-06-06 20:01:25)

  • アマレコTVでGV-USB2を使用してキャプチャーした動画をAviUtlで編集したのですが、倍速編集がうまくできません
    具体的に言うと、動画をA,B、Cに分けて、Bの部分を倍速したいとします。
    Bを中間点で編集できるようにして、その状態でBの再生速度をいじると、なぜか動画Cの一部までが動画Bの部分にされて、倍速がかかります
    そのうえで、C自体は影響を受けてないので、動画が、A、BとCの一部(倍速状態)、C全てとなり、Cが一部だけ倍速されたうえでループしたみたいになります
    環境はWin10です -- 名無しさん (2016-06-05 23:12:29)

2015年


  • ゆっくりムービーメーカーで編集した動画をAviUTLに読み込ませ、自動マルチパスでエンコードしたのですが、何故か動画の冒頭と動画を繋げた部分(フェードアウト編集済)にそれぞれの動画の最後のシーンのフレームが割り込んで、結果的に音ズレしてしまっています。
    何度も編集を繰り返し、プレビューなどでチェックしてもそんなことはないのにエンコードすると何故か最後のフレームが冒頭に混入しちゃいます。
    今までこんなことはなかったのですが、対処法をどなたかお教えください。
    AviUTLの再インストール、プラグインの更新もし、プラグインを変更してみても同じ結果になってしまいます。
    元の動画は音ズレも上記のようなフレームの混入もないので原因がよくわかりません。
    撮影したソフトはShadowPlayで、環境はWin7です。 -- 名無しさん (2015-10-17 13:45:19)

  • 今回ゆっくり実況動画に初挑戦することにしたのですが
    exoファイルを生成しaviutlの拡張機能を使用して再出力しようと試みたのですが
    どうしても動画ファイルが対応してない?みたいなエラーが出て
    画面が真っ黒になったままです


    対処法を教えてもらえませんか? -- フェイ太 (2015-09-26 01:52:05)

  • ↓↓↓アドバイスありがとうございます。おかげでうまくいきました -- 名無しさん (2015-09-26 01:34:39)

  • ↓手動でバックアップ取っておけば対処できます。
    それか自動バックアップで復元する方法もあります。
    ttp://www18.atwiki.jp/live2ch/pages/448.html#id_d33adb24 -- 名無しさん (2015-09-24 19:44:35)

  • 拡張編集で作業中に誤って本編に画像を入れると、
    拡張編集の画像がすべて消えてしまいます
    元に戻せないのでしょうか? -- 亀ちゃん (2015-09-24 11:10:03)

  • ↓AviUtlの画面上部の括弧書きにある数字が
    8の倍数になるように、設定→クリッピング&リサイズの設定を
    いじってください。
    あとこれは余計な話かもしれませんが、Microsoft Video 1は
    使う意味がないですので、x264guiExを導入してMP4出力すると
    いいかと思います。 -- 名無しさん (2015-09-21 20:21:11)

  • 動画をAVI出力しようとすると


    「ビデオ圧縮に失敗しました
    画像サイズやフレームレートを適正に設定しないと
    使用できないコーデックの可能性があります」


    と表示されます。


    ビデオ圧縮は   Microsoft Video1
    オーディオ圧縮は PCM44.100kHz 2ch
    この他には特に設定していません -- 名無しさん (2015-09-20 20:54:46)

  • ↓AviUtl本体で読み込めるかどうかの確認と
    拡張編集プラグインの置き場所を再度確認してみてください。
    ttp://www18.atwiki.jp/live2ch/pages/448.html#id_6e273711 -- 名無しさん (2015-07-07 20:53:43)

  • exedit.iniに拡張子を追加したのに追加した動画形式や音声形式のファイル(例えばWMAファイル)
    が読み込めません。どうすれば良いのでしょうか? -- お願いします (2015-07-07 17:14:06)

2014年


  • 動画を一部加速しようとして失敗しています
    解説の通り、加速開始地点と終了地点に中間点を配置し、その中間点の間に移動。
    再生速度を直線移動にして再生速度を弄ると、なぜか後ろ側の中間点を無視して最後まで再生速度が変化してしまいます -- 名無しさん (2014-12-26 13:23:32)

2013年


  • ↓中間点を追加後、再生速度を変える前に再生速度を
    直線移動にできているでしょうか。解説の手順3の所です。
    念のためAviUtl version1.00と拡張編集Plugin version0.92で
    やってみましたが、こちらでは上手く行きました。 -- 名無しさん (2013-12-30 17:17:24)

  • すみません、今確認したところ、最初に中間点を追加して再生速度を変更した時点で、A地点もそれ以外も全部まとめて再生速度が変化してました。
    多分中間点で切り分けた部分の再生速度だけを変更するっていうのがこの手順の要なんだと思うんですが…なぜこうなるんでしょう?(´ω`) -- (2013-12-29 15:10:03)

  • 再生速度の変更についてお尋ねしたく。
    こちらに書かれている手順通りに操作しているのですが、どうにも上手くいきません。


    例えば動画の頭から、タイムライン全体をA地点、B地点、C地点にわけます。
    B地点のみ再生速度を二倍にすべく、A地点とB地点の接点に中間点を追加し、B地点およびC地点となる部分が選択されているのを確認後、再生速度を200に設定します。
    ここまでの手順では、再生するとA地点は通常の速度で、それ以降が二倍速で再生されます。
    その後B地点とC地点の接点で中間点を追加しました。
    ここまでは手順1~7までの通りに操作していると思います。


    そして、手順8に従いC地点が選択されているのを確認して再生速度を100に戻します。
    するとどうしたことか、中間点と中間点で挟まれたB地点の再生速度も100に戻ってしまいます。
    慌ててB地点の速度を200に変更すると、今度はA地点も含めてオブジェクト全ての再生速度が200に……('A`)
    つまりその…再生速度の変更をすると、中間点とか関係なく全部に変更が及んでしまうんですが、何か間違った操作をしてしまったんでしょうか? -- (2013-12-29 14:49:13)

  • こちらのやり方を参考に動画編集をしようとしています。ありがとうございます。
    編集の際、動画の読み込みがうまくいきません。
    4つまでは正常に読み込むのですが、それ以上読み込もうとすると、例外のエラーとなり、強制終了してしまいます。
    なにかプラグインがうまくインストールできてないのでしょうか?
    メッセージビデオみたいなものを作るため、1人10秒程の動画を撮影しており、
    それをこちらのソフトでつなぎあわせて、編集しようと思っているのですが、てまきなくて困っております。
    同じビデオカメラで撮影しているため、動画の形式は全て同じです。
    よろしくお願いします。 -- 教えください (2013-04-09 08:16:53)

Top > AviUtl拡張編集(2) > 過去のコメント/ 2018年08月10日 (金) 20時18分01秒






| 新しいページ | 編集 | 差分 | 編集履歴 | ページ名変更 | アップロード | 検索 | ページ一覧 | タグ | RSS | ご利用ガイド | 管理者に問合せ |
@wiki - 無料レンタルウィキサービス | プライバシーポリシー